题目

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice:

"Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:

Day 1 2 3 4 5 6 7 8 9 10 11 12
Price 68 69 54 64 68 64 70 67 78 62 98 87

The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:

Day 2 5 6 10
Price 69 68 64 62

Input

  • Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

  • Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.

Output

Two integers on a single line:

  • The length of the longest sequence of decreasing prices
  • The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution.

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

题解

对于每组数据需要输出两个数据,第一个非常明显是最长下降子序列**
参照
>最长上升子序列<**

重点在于第二问:满足最长上升子序列的序列个数(非重复)
按照最长上升子序列的思路,有 dp[i] == dp[j] + 1 && a[i] < a[j]
对于满足上面式子的显然是最长上升子序列的一部分

cnt[i] 记录,到第 i 个数的最长上升子序列的个数(重复)
最后将所有 dp[i] 为最长上升子序列的 cnt[i] 加起来就是个数(重复)

而题目要求是非重复,需要考虑判重
对于 a[i] == a[j] 的情况,可以忽略比当前 j 小的 j 的情况
也即,从大到小循环,发现 a[i] == a[j] ,直接跳出

解释不清,逐步调试看代码吧

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;

const int maxn = 5005;

int a[maxn];
int dp[maxn];
int cnt[maxn];

bool Do() {
    int n;

    if(scanf("%d",&n) == EOF)
        return false;

    for(int i = 1;i <= n;i++) {
        scanf("%d",&a[i]);
    }

    memset(dp,0,sizeof(dp));
    memset(cnt,0,sizeof(cnt));
    cnt[0] = 1;

    int Max = 0;
    for(int i = 1;i <= n;i++) {
        for(int j = i - 1;j >= 0;j--)
            if(a[j] > a[i] || j == 0)
                dp[i] = max(dp[i],dp[j] + 1);
        Max = max(dp[i],Max);
    }

    for(int i = 1;i <= n;i++) {
        for(int j = i - 1;j >= 0;j--) {
            if(a[i] == a[j])
                break;
            if(dp[i] == dp[j] + 1 && (a[i] <= a[j] || j == 0)) {
                cnt[i] += cnt[j];
            }
        }
    }

    int num = 0;
    for(int i = 1;i <= n;i++) {
        if(Max == dp[i])
            num += cnt[i];
    }

    printf("%d %d\n",Max,num);

    return true;

}
int main() {
    while(Do());
    return 0;
}