题目

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题解

贪心算法

  • 分高的作业一定要写
  • 分数一样的优先写时间晚的
  • 作业尽可能晚写
    符合这三个条件即可

算法

/*
By:OhYee
Github:OhYee
Blog:http://www.oyohyee.com/
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <functional>
using namespace std;

const int maxn = 1005;
const int maxt = 900000;
int Deadline[maxn],Score[maxn];
struct Node {
    int Deadline;
    int Score;
    bool operator < (const Node &rhs)const {
        if(Score == rhs.Score)
            return Deadline > rhs.Deadline;
        else
            return Score > rhs.Score;
    }
};
Node node[maxn];
int Time[maxt];

bool Do() {
    int n;
    scanf("%d",&n);
    int sum = 0;
    int mt = 0;
    for(int i = 1;i <= n;i++) {
        scanf("%d",&node[i].Deadline);
        mt = max(mt,node[i].Deadline);
    }
    for(int i = 1;i <= n;i++) {
        scanf("%d",&node[i].Score);
        sum += node[i].Score;
    }

    sort(node + 1,node + 1 + n);

    for(int i = 0;i <= mt + 1;i++)
        Time[i] = i;

    int ans = 0;
    for(int i = 1;i <= n;i++) {
        int k = node[i].Deadline;
        int t = Time[k];
        while(!(t == k || t == 0 || k == 0)) {
            k = Time[k];
            t = Time[t];
        }
        if(t == k && t != 0) {
            Time[k]--;
            ans += node[i].Score;
        }
    }

    printf("%d\n",sum - ans);

    return true;
}


int main() {
    int T;
    scanf("%d",&T);
    while(T--)
        Do();
    return 0;
}