题目

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题解

将所有的点连接起来,使总距离最小

>最小生成树问题<
直接套用模板即可

代码

/*
By:OhYee
Github:OhYee
Blog:http://www.oyohyee.com/
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <functional>
#include <bitset>
using namespace std;

const int maxn = 105;

struct Edge {
    int u,v;
    int w;
    bool operator < (const Edge &rhs)const {
        return w < rhs.w;
    }
};


int f[maxn];
Edge e[maxn*maxn / 2];

int ufs(int x) {
    return f[x] == x ? x : f[x] = ufs(f[x]);
}
int Kruskal(int n,int m) {
    int w = 0;
    for(int i = 0; i < n; i++)
        f[i] = i;
    sort(e,e + m);
    for(int i = 0; i < m; i++) {
        int x = ufs(e[i].u),y = ufs(e[i].v);
        if(x != y) {
            f[x] = y;
            w += e[i].w;
        }
    }
    return w;
}

bool Do() {
    int n;
    if(!(cin >> n))
        return false;

    int pos = 0;
    for(int i = 0;i < n;i++)
        for(int j = 0;j < n;j++) {
            if(i < j) {
                e[pos].u = i;
                e[pos].v = j;
                cin >> e[pos].w;
                pos++;
            } else {
                int t;
                cin >> t;
            }
        }



    cout << Kruskal(n,n*(n-1)/2) << endl;

    return true;
}

int main() {
    cin.tie(0);
    cin.sync_with_stdio(false);

    while(Do());
    return 0;
}