题目

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

题解

dp[i]表示买前i种珍珠所需要的最少的钱数
根据贪心,买第i种珍珠时,买的越多越划算。
也即,对于第i种珍珠,要么一个都不买,要么把前面更便宜的没买的和本组该买的都买了

因此,对于每一层, 只有买和不买两种选择
并且不可能出现便宜的没买但是贵的买了

dp[i]= min{ dp[i-1] + (num[i] + 10)*price[i] , dp[j] + (sum[i] - sum[j] + 10)*price[i] } 0<=j<i

前部分是每一组都买的情况,后部分是j~i未买的情况

不要使用sort排序,会WA。

就按照输入的顺序计算即可,不考虑不是按照价钱从小到大输入的情况

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com
Blog:http://www.cnblogs.com/ohyee/

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/


#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
using namespace std;

//DEBUG MODE
#define debug 0

//循环
#define REP(n) for(int o=0;o<n;o++)

/*
    题意理解:
        珍珠有不同的价格,需要买一定数量指定价格的珍珠
        对于买的一种价格的珍珠,需要额外付出10个该类珍珠价格的手续费
        可以用更好的珠宝代替较差的珍珠

        求出所花费的最小价格
*/
typedef int LL;

const int maxn = 105;

struct Pearl {
    int num;
    int price;
    bool operator < (const Pearl &rhs)const {
        return price < rhs.price;
    }
};

Pearl p[maxn];

//买完前i种珍珠所需要的最小值
LL dp[maxn];

int m[maxn];

void Do() {
    int n;
    scanf("%d",&n);
    m[0] = 0;
    REP(n)
        scanf("%d%d",&p[o + 1].num,&p[o + 1].price);
    memset(dp,0,sizeof(dp));
    //sort(p + 1,p + 1 + n);
    REP(n)
        m[o + 1] = m[o] + p[o+1].num;

    for(int i = 1;i <= n;i++) {
        dp[i] = dp[i - 1] + (p[i].num + 10) * p[i].price;
        for(int j = 0;j < i;j++)
            dp[i] = min(dp[i],dp[j] + (LL)(m[i] - m[j] + 10) * p[i].price);
    }
    printf("%d\n",dp[n]);

    return;
}

int main() {
    int T;
    scanf("%d",&T);
    while(T--)
        Do();
    return 0;
}