题目

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

Original Transformed
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

Original Transformed
30

题解

原题
>AOJ 806.算法期末考试B(动态规划)<
>HDU 2084.数塔<

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com
Blog:http://www.cnblogs.com/ohyee/
  
かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/
  
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
  
//DEBUG MODE
#define debug 0
  
//循环
#define REP(n) for(int o=0;o<n;o++)
  
const int maxn = 1000;
  
int Map[maxn][maxn];
  
bool Do() {
    int n;
      
    if(scanf("%d",&n) == EOF)
        return false;
  
    memset(Map,0,sizeof(Map));
  
    for(int i = 1;i <= n;i++)
        for(int j = 1;j <= i;j++)
            scanf("%d",&Map[i][j]);
  
    for(int i = n - 1;i > 0;i--)
        for(int j = 1;j <= i;j++)
            Map[i][j] += max(Map[i + 1][j],Map[i + 1][j + 1]);
    printf("%d\n",Map[1][1]);
    return true;
}
  
int main() {
    while(Do());
    return 0;
}