题目

Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

题解

跟着样例自己模拟,很容易可以看出是求最长上升子序列
输入两个数 sv
先对 s 排序,再对 v 求最长上升子序列

由于数据较大,采用二分法求最长上升子序列( O(nlogn) )
注意最后输出,如果结果大于 2 要把 road 变成 roads

如果采用 STLlower_bound() 函数,需要注意它需要使用 <
要注意和前面 sort() 的区分

明明一眼看出算法,还坑了那么久……

代码

/*
By:OhYee
Github:OhYee
Blog:http://www.oyohyee.com/
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <functional>
#include <bitset>
using namespace std;

const int maxn = 500005;
int kase = 1;

struct Node {
    int s;
    int v;
    int right;
    //bool operator < (const Node &rhs)const {
        //return s < rhs.s;
    //}
    bool operator < (const Node &rhs)const {
        return v < rhs.v;
    }
    bool operator > (const Node &rhs)const {
        return v > rhs.v;
    }
    static bool compare(Node &a,Node &b) {
        return a.s < b.s;
    }
};
Node node[maxn];
Node ans[maxn];


bool Do() {
    int n;
    if(scanf("%d",&n) == EOF)
        return false;
    for(int i = 1;i <= n;i++) {
        scanf("%d%d",&node[i].s,&node[i].v);
        //dp[i] = 0;
    }

    /*
    int ans = 0;
    for(int i = 1;i <= n;i++) {
        for(int j = 0;j < i;j++)
            if(node[i] > node[j] || j == 0) {
                dp[i] = max(dp[i],dp[j] + 1);
            }
        ans = max(ans,dp[i]);
    }
    */
    sort(node + 1,node + 1 + n,Node::compare);

    ans[1] = node[1];
    int len = 1;
    for(int i = 2; i <= n; ++i) {
        if(node[i] > ans[len])
            ans[++len] = node[i];
        else {
            Node *t = lower_bound(ans + 1,ans + 1 + len,node[i]);
            *(t) = node[i];
        }
    }

    if(len == 1)
        printf("Case %d:\nMy king, at most %d road can be built.\n\n",kase++,len);
    else
        printf("Case %d:\nMy king, at most %d roads can be built.\n\n",kase++,len);
    return true;
}

int main() {
    while(Do());
    return 0;
}