题目

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

  • deleting of one letter from the word;
  • replacing of one letter in the word with an arbitrary letter;
  • inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award

me
aware
m
contest
hav
oo
or
i
fi
mre

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

题解

给一些合法单词和一些待测的单词,如果待测单词合法,则输出“xx is correct”。

否则,输出删去、修改、增加一个字符后合法的单词

输出按照输入顺序

有个题解说用Trie树,写的一直WA、TLE

换用暴力

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com
Blog:http://www.cnblogs.com/ohyee/

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
using namespace std;

//DEBUG MODE
#define debug 0

//循环
#define REP(n) for(int o=0;o<n;o++)

int ok;
int ldict,lstr;
string temp;
vector<string> dict;


void replace(string dict) {
    int count = 0;
    for(size_t i = 0; i < dict.length(); i++) {
        if(temp[i] != dict[i]) count++;
        if(count > 1) return;
    }
    ok = 1;
    cout << " " + dict;
}

void insert(string dict) {
    string tmp;
    for(size_t i = 0; i < temp.length(); i++) {
        if(temp[i] != dict[i]) {
            tmp = dict;
            tmp.insert(i,1,temp[i]);
            if(tmp == temp) {
                ok = 1;
                cout << " " + dict;
            }
            return;
        }
    }
}

void del(string dict) {
    string tmp;
    for(size_t i = 0; i < dict.length(); i++) {
        if(temp[i] != dict[i]) {
            tmp = dict;
            tmp.erase(i,1);
            if(tmp == temp) {
                ok = 1;
                cout << " " + dict;
            }
            return;
        }
    }
}

bool Do() {
    while(1) {
        if(!(cin >> temp))
            return false;
        if(temp == "#") break;
        dict.push_back(temp);
    }

    while(1) {
        cin >> temp;
        if(temp == "#") break;

        ok = -1;
        lstr = temp.length();

        for(size_t i = 0; i < dict.size(); i++) {
            if(dict[i] == temp) {
                cout << temp + " is correct";
                ok = 0;
                break;
            }
        }


        if(ok < 0) {
            cout << temp + ':';
            for(size_t i = 0; i < dict.size(); i++) {
                ldict = dict[i].length();
                if(lstr == ldict) {
                    replace(dict[i]);
                } else if(lstr == ldict + 1) {
                    insert(dict[i]);
                } else if(lstr == ldict - 1) {
                    del(dict[i]);
                }
            }
        }

        cout << endl;
    }

    return true;
}

int main() {
    while(Do());
    return 0;
}