题目

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

题解

计算使用 10000 内的素数相加可以组成的数,求指定数相加的方案数

筛法求素数 然后打表计算即可

代码

/*
By:OhYee
Github:OhYee
Blog:http://www.oyohyee.com/
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <string>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

typedef long long LL;

const int INF = 0x7FFFFFFF;
const double eps = 1e-10;

const int maxn = 100005;


int prime[maxn] = {0},num_prime = 0;
bool isNotPrime[maxn] = {1,1};

LL cnt[maxn];
LL sum[maxn];

bool Do() {
    int n;
    cin >> n;
    if(n==0)
        return false;
    cout << cnt[n] << endl;

    return true;
}

int main() {
    cin.tie(0);
    cin.sync_with_stdio(false);

    for(long i = 2;i<maxn;i++) {
        if(!isNotPrime[i])prime[num_prime++] = i;
        for(int j = 0;j<num_prime&&i*prime[j]<maxn;j++) {
            isNotPrime[i*prime[j]] = true;
            if(!(i%prime[j]))break;
        }
    }

    memset(cnt,0,sizeof(cnt));

    sum[0] = prime[0];
    for(int i = 1;i < num_prime;i++)
        sum[i] = sum[i - 1] + prime[i];

    for(int i = 0;i < num_prime;i++) {
        if(sum[i] < maxn)
            cnt[sum[i]]++;
        for(int j = i + 1;j < num_prime;j++) {
            LL s = sum[j] - sum[i];
            if(s < maxn)
                cnt[s]++;
        }
    }
            

    while(Do());

    return 0;
}