题目

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the Sample Output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

题解

>丑数<
丑数部分直接套用公式即可,这道题难点明明是英语……
stndrdth 花的时间比丑数都多……

代码

/*
By:OhYee
Github:OhYee
HomePage:http://www.oyohyee.com
Email:oyohyee@oyohyee.com

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;

const int maxn = 5843;

int dp[maxn];
char *c[] = {"","st","nd","rd"};

bool  Do() {
    int n;
    scanf("%d",&n);
    if(n == 0)
        return false;

    char t[3]="th";
    if(n % 10 == 1 && n % 100 != 11)
        t[0] = 's',t[1]='t';
    else if(n % 10 == 2 && n % 100 != 12)
        t[0] = 'n',t[1] = 'd';
    else if(n % 10 == 3 && n % 100 != 13)
        t[0] = 'r',t[1] = 'd';

    printf("The %d%s humble number is %d.\n",n,t,dp[n]);
    return true;
}

int main() {
    int i1 = 1,i2 = 1,i3 = 1,i4 = 1;
    int n = 1;
    dp[1] = 1;
    while(n < maxn) {
        dp[++n] = min(min(2 * dp[i1],3 * dp[i2]),min(5 * dp[i3],7 * dp[i4]));
        if(dp[n] == 2 * dp[i1]) i1++;
        if(dp[n] == 3 * dp[i2]) i2++;
        if(dp[n] == 5 * dp[i3]) i3++;
        if(dp[n] == 7 * dp[i4]) i4++;
    }

    while(Do());
    return 0;
}