题目

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

题解

题目是三维的BFS,思路上比较明确,类似BFS从一维拓展成二维,将BFS从二维拓展成三维即可

不过该题数据量较大,需要进行各种优化

当达到时间限制后,就不必再进行BFS了,应该直接输出-1

当找到答案后,就不必进行BFS了,应该直接输出答案

不过第一次尽管这样处理还是TLE,于是又优化了下读入

int read_int() {
    char c;
    int ans = 0;
    while(c = getchar(),!(c >= '0' && c <= '9'));
    while(c >= '0' && c <= '9') {
        ans *= 10;
        ans += (int)c - '0';
        c = getchar();
    }
    return ans;
}

不过第一次写的有点小问题,导致WA。

看了下问题出在优化输入上,修改了下后AC

代码

/*
By:OhYee
Github:OhYee
Email:oyohyee@oyohyee.com
Blog:http://www.cnblogs.com/ohyee/

かしこいかわいい?
エリーチカ!
要写出来Хорошо的代码哦~
*/

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <iostream>
#include <vector>
#include <list>
#include <queue>
#include <stack>
#include <map>
using namespace std;

//DEBUG MODE
#define debug 0

//循环
#define REP(n) for(int o=0;o<n;o++)

const int maxn = 55;
int a,b,c;
int t;
int dis[maxn][maxn][maxn];
int Map[maxn][maxn][maxn];

const int delta[6][3] = {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};

struct point {
    int x,y,z;
    point() {
        x = y = z = -1;
    }
    point(int a,int b,int c) {
        x = a;
        y = b;
        z = c;
    }
};

//优化输入
int read_int() {
    char c;
    int ans = 0;
    while(c = getchar(),!(c >= '0' && c <= '9'));
    while(c >= '0' && c <= '9') {
        ans *= 10;
        ans += (int)c - '0';
        c = getchar();
    }
    return ans;
}


int BFS(point s,point v) {
    memset(dis,-1,sizeof(dis));
    queue<point> Q;

    Q.push(s);
    dis[s.x][s.y][s.z] = 0;

    while(!Q.empty()) {
        int x = Q.front().x;
        int y = Q.front().y;
        int z = Q.front().z;
        Q.pop();

        //时间已到
        if(dis[x][y][z] >= t)
            return -1;

        REP(6) {
            int xx = x + delta[o][0];
            int yy = y + delta[o][1];
            int zz = z + delta[o][2];

            //非法路径
            if(xx < 0 || xx >= a || yy < 0 || yy >= b || zz < 0 || zz >= c)
                continue;
            //墙
            if(Map[xx][yy][zz] == 1)
                continue;

            //尚未访问过
            if(dis[xx][yy][zz] == -1) {
                dis[xx][yy][zz] = dis[x][y][z] + 1;
                //到达终点
                if(xx == v.x && yy == v.y && zz == v.z)
                    return dis[xx][yy][zz];
                Q.push(point(xx,yy,zz));
            }
        }
    }
    return -1;
}

void Do() {
    //scanf("%d%d%d%d",&a,&b,&c,&t);
    a = read_int();
    b = read_int();
    c = read_int();
    t = read_int();


    for(int k = 0;k < a;k++)//块
        for(int i = 0;i < b;i++)//行
            for(int j = 0;j < c;j++)//列
                //scanf("\n%c\n",&Map[k][i][j]);
                Map[k][i][j] = read_int();

   if debug
    for(int k = 0;k < a;k++) {
        for(int i = 0;i < b;i++) {
            for(int j = 0;j < c;j++)
                printf("%d",Map[k][i][j]);
            printf("\n");
        }
        printf("\n");
    }
   endif

    if(a*b*c == 1)
        printf("0\n");
    else
        printf("%d\n",BFS(point(0,0,0),point(a - 1,b - 1,c - 1)));
}

int main() {
    int T;
    T = read_int();
    //scanf("%d",&T);
    while(T--)
        Do();
    return 0;
}