题目

原题链接

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入格式:
输入第1行给出3个正整数,分别为:N(<=10^5^),即考生总数;L(>=60),为录取最低分数线,即德分和才分均不低于L的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线L的考生也按总分排序,但排在第三类考生之后。

随后N行,每行给出一位考生的信息,包括:准考证号、德分、才分,其中准考证号为8位整数,德才分为区间[0,
100]内的整数。数字间以空格分隔。

输出格式:
输出第1行首先给出达到最低分数线的考生人数M,随后M行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

解析

时限已经到了Python也过不了的情况了,所以以后看情况决定要不要写Java和Python吧
这道题的收获在于,Python3.x的sort中cmp函数的使用
from functools import cmp_to_key

代码

C++解法

#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;

const int maxn = 1e5 + 5;
int n, L, H;

struct Node {
    int id, d, c;
    Node() {}
    Node(int _id, int _d, int _c) : id(_id), d(_d), c(_c) {}

    static int getGrade(const Node stu) {
        if (stu.d >= H && stu.c >= H)
            return 4;
        else if (stu.d >= H && stu.c < H)
            return 3;
        else if (stu.d < H && stu.c < H && stu.d >= stu.c)
            return 2;
        else
            return 1;
    }
    bool operator<(const Node &rhs) const {
        const Node stu1 = *this;
        const Node stu2 = rhs;
        int gstu1 = Node::getGrade(stu1);
        int gstu2 = Node::getGrade(stu2);
        int ret = 0;
        if (gstu1 == gstu2)
            if ((stu1.d + stu1.c) == (stu2.d + stu2.c))
                if (stu1.d == stu2.d)
                    ret = stu2.id - stu1.id;
                else
                    ret = stu1.d - stu2.d;
            else
                ret = (stu1.d + stu1.c) - (stu2.d + stu2.c);
        else
            ret = gstu1 - gstu2;
        return ret > 0 ? true : false;
    }
};

Node stus[maxn];
int main() {
    cin.tie(0);
    cin.sync_with_stdio(false);

    cin >> n >> L >> H;

    int m = 0;
    for (int i = 0; i < n; ++i) {
        int a, b, c;
        cin >> a >> b >> c;
        if (b >= L && c >= L)
            stus[m++] = Node(a, b, c);
    }

    sort(stus, stus + m);

    printf("%d\n", m);
    for (int i = 0; i < m; ++i)
        printf("%d %d %d\n", stus[i].id, stus[i].d, stus[i].c);

    return 0;
}

Python解法

from functools import cmp_to_key
import re

def compare(stu1, stu2):
    def getGrade(stu):
        if stu[1] >= c and stu[2] >= c:
            return 4
        elif stu[1] >= c and stu[2] < c:
            return 3
        elif stu[1] < c and stu[2] < c and stu[1] >= stu[2]:
            return 2
        else:
            return 1
    gstu1 = getGrade(stu1)
    gstu2 = getGrade(stu2)
    ret = 0
    if gstu1 == gstu2:
        if (stu1[1] + stu1[2]) == (stu2[1] + stu2[2]):
            if stu1[1] == stu2[1]:
                ret = stu2[0] - stu1[0]
            else:
                ret = stu1[1] - stu2[1]
        else:
            ret = (stu1[1] + stu1[2]) - (stu2[1] + stu2[2])
    else:
        ret = gstu1 - gstu2
    return ret

def inputInt():
    return [int(i) for i in re.findall(r"[0-9]+",input())]


(a, b, c) = inputInt()
lst = []
for i in range(a):
    stu = inputInt()
    if stu[1] >= b and stu[2] >= b:
        lst.append(stu)
lst.sort(key=cmp_to_key(compare), reverse=True)

print(len(lst))
for i in lst:
    print(" ".join([str(j) for j in i]))