题目

原题链接

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为7572、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得72 + 45/2 = 94.5(亿元)。

输入格式:
每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:
3 20
18 15 10
75 72 45

输出样例:
94.50

解析

贪心即可,需要注意的是,输出结果需要四舍五入

代码

C++解法

#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;
const int maxn = 1005;
const double eps = 1e-9;

struct Node {
    double w, p;
    double getPrice() const { return p / w; }
    bool operator<(const Node &rhs) const {
        return getPrice() > rhs.getPrice();
    }
};
Node goods[maxn];

int sgn(double n) { return fabs(n) < eps ? 0 : n > 0 ? 1 : -1; }
int double_round(double n) { return sgn(n) > 0 ? n + 0.5 : n - 0.5; }

int main() {
    int n, D;
    scanf("%d%d", &n, &D);
    for (int i = 0; i < n; ++i)
        scanf("%lf", &goods[i].w);
    for (int i = 0; i < n; ++i)
        scanf("%lf", &goods[i].p);
    sort(goods, goods + n);

    double ans = 0.0;
    for (int i = 0; i < n && D > 0; ++i) {
        if (D >= goods[i].w) {
            ans += goods[i].p;
            D -= goods[i].w;
        } else {
            ans += goods[i].getPrice() * D;
            D = 0;
        }
    }
    printf("%.2f\n", (double)double_round(ans * 100) / 100);
    return 0;
}

Python解法

(n, D) = [int(i) for i in input().split(" ")]
w = [float(i) for i in input().split(" ")]
p = [float(i) for i in input().split(" ")]
node = [(w[i], p[i]) for i in range(n)]
node.sort(key=lambda x: x[1] / x[0], reverse=True)
ans = 0.0
for i in range(n):
    if D >= node[i][0]:
        ans += node[i][1]
        D -= node[i][0]
    else:
        ans += D * node[i][1] / node[i][0]
        D = 0
    if D == 0:
        break
print("%.2f" % (round(ans * 100) / 100))